Donate Now
We've Moved! Check out our new boards.
  New Poll  
my profile | directory login | search | faq | forum home

  next oldest topic   next newest topic
» Scarleteen Boards: 2000 - 2014 (Archive) » SCARLETEEN CENTRAL » Bodies » Not sure if this is a topic for this site, but here goes.

 - UBBFriend: Email this page to someone!    
Author Topic: Not sure if this is a topic for this site, but here goes.
BriAnne86
Neophyte
Member # 48343

Icon 1 posted      Profile for BriAnne86     Send New Private Message       Edit/Delete Post 
I'm not sure if this is sex-related but I figured it wouldn't hurt to ask; maybe I can get some insight.

Recently (like within the last 2-3 months) I've noticed that at times when I urinate, I have this uncomfortable feeling. I don't really know how to explain it other than it feels (near the end of the urination) that my urethra is being pulled out with it. It doesn't "burn" as if I have a uti (I don't have one by the way, that was my first thought when this first started happening). It doesn't even hurt super bad, it's just really uncomfortable.

Also (and I don't know if this is related to the above issue or not), I noticed that I go through cycles where my urine stream will be very low. It doesn't seem to matter how much or little I drink during the day. There are times where I'll go for a week and have a really strong stream, and then all the sudden it goes back to almost nothing, even when I try to "push" the urine out (and when I do have a stronger stream, I don't have to "push", it just does it naturally). Sorry if this is TMI, I'm just trying to explain the details.

I'm not sure if these things are related to 1)each other and 2) sex. I do know that I never had either of these issues prior to losing my virginity in October. However, these issues haven't popped up until more recently. I would assume that if they were related to sex that they might have come up quicker? But I guess I don't know.

Since I've started having sex, I've had a uti twice. Once after the first series of sex sessions and once after the third series of sex sessions. I haven't had any since then (been trying to do as much as possible to prevent them). Is it possible that there was damage to my bladder or urethra from the uti's? Like I said, these issues didn't start happening until recently, and they come in cycles. Sometimes I'm completely "normal" (no odd feeling, regular urine stream) and sometimes one issue or both occurs. In other words it's not a consistent problem.

I also don't have any other symptoms of anything being wrong. I suppose I could go to a urologist but I don't know if what's happening with me is anything that really warrants a visit, since they don't seem to affect me physically.

Thanks! And sorry so long...

Posts: 34 | From: Ohio | Registered: Aug 2010  |  IP: Logged | Report this post to a Moderator
Karybu
Scarleteen Volunteer
Member # 20094

Icon 1 posted      Profile for Karybu     Send New Private Message       Edit/Delete Post 
Have you been tested again for a UTI to make sure your last one cleared up completely? Sometimes one course of antibiotics doesn't do the trick, and although most symptoms go away the infection isn't totally gone. So, I'd start by heading back to your doctor and making sure that's not the problem here; if it isn't, they'll be able to look into this further.

--------------------
"Another world is not only possible, she is on her way. On a quiet day, I can hear her breathing." -Arundhati Roy

Posts: 5799 | From: Canada/Australia | Registered: Sep 2004  |  IP: Logged | Report this post to a Moderator
BriAnne86
Neophyte
Member # 48343

Icon 1 posted      Profile for BriAnne86     Send New Private Message       Edit/Delete Post 
Sorry it took me so long to respond.

Yes, I was tested when I started having this issue. It had been several weeks, more like months since I had my last uti, but when this started happening I got tested again because I thought that's what it might be. It was all I could think of, even though the "burning" I feel isn't the same kind of burning I get with uti's. Actually, my last uti didn't have any burning but I think that's because the infection itself was in my bladder and not my urethra.

But back on point, no, no uti. However I will say that since I posted the original question, I haven't had the issue, so it's been about 2 weeks of normalcy. I'm just not really sure what to make of it, but since it's not causing me any real problems (other than being annoying) I'm not too concerned. I was just wondering if anyone here might have an idea of what it is. If it keeps up or gets worse somehow I'll see a doc.

Posts: 34 | From: Ohio | Registered: Aug 2010  |  IP: Logged | Report this post to a Moderator
   

  New Poll   Close Topic   Feature Topic   Move Topic   Delete Topic next oldest topic   next newest topic
 - Printer-friendly view of this topic
Hop To:


Contact Us | Get the Whole Story! Go Home to SCARLETEEN: Sex Ed for the Real World | Privacy Statement

Copyright 1998, 2014 Heather Corinna/Scarleteen
Scarleteen.com: Providing comprehensive sex education online to teens and young adults worldwide since 1998

Information on this site is provided for educational purposes. It is not meant to and cannot substitute for advice or care provided by an in-person medical professional. The information contained herein is not meant to be used to diagnose or treat a health problem or disease, or for prescribing any medication. You should always consult your own healthcare provider if you have a health problem or medical condition.

Powered by UBB.classic™ 6.7.3